There are two components to The Clusternator. The command line client, and the server.

Client Requirements

  • NodeJs >= 12
  • GPG ~1.4 not included in OS X or Windows. As of 2017 brew install gpg1 and symlinking to /usr/local/bin/gpg is the easiest
  • OpenSSH (included on OS X, GNU/Linux)
  • Docker (optional)

Server Requirements

The server is designed to be deployed as a Docker container, so in a way, Docker is a requirement.